Firefox 3 RC1: Plugin Incompatibility


A problem with Firefox 3 is that not all plugins are ready for deployment. The attached image shows my current set (on my laptop I have a couple more). Of particular note are del.icio.us, ScribeFire (for in-browser blogging) and Zotero (bibliographic database).

Google gears is also not yet compatible so support for offline working for Gmail, Google Reader, and Google Docs will not work. I find that I don’t travel enough with my lap top for this to be an issue.

I assume that most plugin providers are waiting on the final release before upgrading their plugins, but if any plugin is important to you, it might be worth holding off installing Firefox 3 for now. If you want to try it, a portable version of Firefox 3 RC1 that runs from a USB memory stick is also available. Alternatively you can run Firefox 2 and 3 on the same machine if you create a new profile for the latter. I wish I’d done that!

Update

I just discovered that there’s a beta version of the del.icio.us plugin for Firefox, so that’s one indispensible tool that I won’t have to live without!

Author: cpjobling

Senior lecturer, College of Engineering, Swansea University